
-----------------------
Section 1. Introduction
-----------------------

This guide will step through an example of welding a 3 pass overlay weld on a single part 
(in the example, a simple rectangular plate)

Setup Weld Project Video (Click to Play)

-------------------
Section 2. PreSetup
-------------------

See help for the "PreSetup" window.
Click "View Window" button below, then press <F1> key for help.

--------------------------------------------------------------

The usual case for this window is that we just accept the default settings.

-------------------------
Section 3. Load STL files
-------------------------

See help for the "StlFiles" window.
Click "View Window" button below, then press <F1> key for help.

--------------------------------------------------------------

For our example, open  Setup -> Stl files or click "View Window" button below

1) - Click the "Copy stl files from" button and in the popup widget navigate to the 
directory where the stl files are stored and click OK.
    - in our test, this brings a file called PlateOnPlate.stl into the list of stl files.

2) - If you have more than one part in any stl files you need to split these into separate 
stl files.  Either select the file in the list and click the "Split stl file" button or 
click the "Split all stl files" button.
     - In our example this returns 2 stl files:
       PlateOnPlate_subset0001.stl
       PlateOnPlate_subset0002.stl

3) - Visualize all stlfiles by clicking "Visualize all stl files" button.
     In the Visualizer, for our example, we see 2 rectangular plates.  A small one on top 
of a larger one.  We plan to weld on the smaller one and use the larger one simply as a 
fixture.

4) - Scale to meters -  All stlfile MUST be in meters for the software to behave properly.
    - Press the first mouse button in the Visualizer window and keep holding the button.  
Move the mouse a bit.  Along the bottom of the Visualizer you should see the min max 
dimensions of the stls in meters.  From this, you can determine if you need to scale and by 
how much. 

http://www.goldaktec.com/VrWeldSetupProjectVideo.html


    - In our example, we see 200 x 36 x 400   Clearly we are not going to weld something 
that is 400 meters   We know that we really have parts that are 200 x 36 x 400 mm so we 
need to scale mm to meters.  Just click the "mm to meters" button or type the scale factor 
into the slot next to the Scale button if it is not one of the 3 given conversions.
   - You can repeat the visualizer check again to see if the dimensions reported along the 
botton of the visualizer window are correct now.
     we see 0.2 x 0.036 x 0.4 now

- Close the viuslizer and the Stlfiles window

-------------------------------
Section 4. Setup part type info
-------------------------------

See help for the "PartTypeInfo" window.
Click "View Window" button below, then press <F1> key for help.

--------------------------------------------------------------

Open the Setup -> Part type info window or click "View Window" button below

- you need to assign stlfiles to part types.  You do this by selecting the Part type in the 
list on the left and entering a substring from the stlfile name in the upper right 
SubString widget which distinguishes the desired file or files.  Then click the "Update stl 
files" button.  You can enter several substrings or sometimes it is even appropriate to 
enter * and bring every stlfile in.

- in our example, we select "Body" and enter substring "0001"
  The file PlateOnPlate_subset0001.stl appears in the list on the right.
- we the select "Constraint" and enter substring "0002"
  The file PlateOnPlate_subset0002.stl appears in the list on the right.

The other Part types are left blank in this example.

--You can also change the Material for each Part type by selecting the part type and the 
selecting from the menu in the lower left.  Press Apply for each part type.

  For our example we set to PriceLowAlloySteel

 

---------------------
Section 5. PreProcess
---------------------

See help for the "PreProcess" window.
Click "View Window" button below, then press <F1> key for help.



--------------------------------------------------------------

Note:  for the single part case the "Make STL adjacency graph" button need not be pressed.  
If you do, it will give an Error.  Ignore it.

--------------------------------
Section 6. Assign part adjacency
--------------------------------

See help for the "Part Adjacency" window.
Click "View Window" button below, then press <F1> key for help.

--------------------------------------------------------------

Note:  for the single part case this step is not needed.  If you do, it will give an Error.  
Ignore it and continue.

--------------------------
Section 7. Pick weld paths
--------------------------

Since this guide is mainly concerned with welding on a single part we will only discuss the 
PointCurve method.  You can read about other weldpath picking methods in other guides such 
as the regular "Prepare welding Project" guide.

-------------------------------------------------------------------------

1. Open Setup -> Stl Files (or click "View Window" below). 

2. Click "Visualize all stl files" in the "Stl Files" window.
This pops up  with all stl files. 

3. Open Tools -> "WeldPath - PointCurve" window in SMTVisualizer to pick weld paths.  then 
press <F1> key for help.

-----------------------------------------------------------------

For our example, we just pick 2 points right down the center of the smaller plate and save 
in a file called wp1

--------------------------
Section 8. Mesh weld paths
--------------------------

Since this guide is mainly concerned with welding on a single part we will only discuss the 
PointCurve method.  You can read about other weldpath picking methods in other guides such 
as the regular "Prepare welding Project" guide.

-------------------------------------------------------------------------



1. Open the Meshing -> Predefine -> WeldPath -> Edit window from the main menu (or click 
"View Window" button below).

2. Set the WeldPath Type to: PointCurve.

3. Select the filename of the weldpath points saved in the previous step

Set up the rest of the meshing parameters (see F1 help for this window) and save parameters 
with "OK" button.
 
3. Click "Meshing -> PreDefined -> WeldPath -> Make".

4. Click "Meshing -> PreDefined -> WeldPath -> Visualize".
   You may need to rotate to see the path if it is in the Z direction

-------------------------------------------------------------------------
for our example,  

WeldPath Type:  PointCurve
WeldPath name:  wp1

maxElemSize     0.005

all other parameters, accept the defaults.

--------------------------
Section 9. Weld Path Group
--------------------------

1. Open the Meshing -> Predefine -> WeldPath -> Edit window from the main menu (or click 
"View Window" button below).

2. WeldPathGroup -> Make  

3. WeldPathGroup -> Visualize 

----------------------------------
Section 10. Create weld procedures
----------------------------------

See help for the "Weld Procedure" window.
Click "View Window" button below, then press <F1> key for help.

Create Weld Procedure Video (Click to Play)

-------------------------------------------------------------
For our example,

1) - Click New and enter a name for a weldprocedure in the popup widget
     For example, type  a   and click ok

    This creates a new weld procedure with default settings.

http://www.goldaktec.com/VrWeldCreateProcedureVideo.html


For our example we alter the values to be:

Weld Speed:        0.006 m/s
Wire diameter:     0.0016 m
Voltage:          29.0
Current:         270.0
Arc Efficiency:    0.85

Front:   0.008
Rear:    0.016
Width;   0.0085
depth:   0.008

Click Apply and then OK

------------------------------
Section 11. Create weld joints
------------------------------

At this point you only need to do one step in the "WeldJoint" window.

1. Click "LoadWeldPaths" button.
This creates the list of weld joints with default parameters for the 
filename which was selected for making weld paths.

Also see help for the "WeldJoint" window.
Click "View Window" button below, then press <F1> key for help.

------------------------------------------------------------------

----------------------------
Section 12. Mesh weld joints
----------------------------

Since this is for a special case (One part, multipass) we will discuss only the relavant 
case here.  Other guides discuss other possibilities

Expand this entry and follow the steps....

--------------------------------------------------------
Section 12.1. Mesh weld joints: Make Big WeldJointByTube
--------------------------------------------------------

Meshing -> Predfined -> WeldJointByTube1 or click "View Window" button below

The method we will use here, first makes a WeldJointByTube which is larger than the desired 
final weld profile.  That is, make a large Tube, large enough to encompass all the weld 
passes geometry to will need.  The later steps will make tha actual passes profile geometry 
that will be solved.



1) - In the WeldJoint window select the desired weldpath
     In our example, there is only one.

2) - In the WeldJointByTube1 window, click the "Set current weld joint"
     note that the weldpath number appears next to weldPathIds:

3) - Choose a radius large enough to encompass all the weld passes 
     - for our example, 0.03
4) - cornerSize - because this is on a flat surface of only one part set this to 0.0

5) - fakeSize: Since only one part need only one number, 
     in the example, set this to 0.03  

6) - change the nbElementsOnArc to at least 5 to make a good half circle

7) - fakeLayers: in example, set to 2

8) - shift: in example, set to 0.0

9) - nbElementsThroughThickness:  in example, set to 3

10) - thickness: in example, set to thickness of the plate 0.012
      Hint: If you don't know it, You can determine this using the visualizer Tools -> 
Slider

11) - click Apply and OK

Leave "Pattern Mesh 2D" set to none  for now.

12) - Meshing -> Predfined -> WeldJointByTube1 -> Make
13) - Meshing -> Predfined -> WeldJointByTube1 -> Visualize

 Close Visualizer.

----------------------------------------------------------
Section 12.2. Mesh weld joints: Make crossSection Linemesh
----------------------------------------------------------

Mesh Weld Joints Video (Click to Play)

After we have our Big Tube from the previous step we want to use the Electrode points 
picker to make our multi-pass profile geometries.

Because this is only one part, our usual methods for getting a crossSection, such as using 
the WeldGroup weldjoint maker do not work right now.  We will instead make ourselves a 
LineMesh using a special mesher found in the Meshing -> UserMade window.  

* - To start, open the Setup -> StlFiles window and visualize the part you need the cross 
section of.  In our example, choose PlateOnPlate_subset0001.stl

* - Open the visualizer's Tools -> Multi Point Picker and choose a set of points on your 

http://www.goldaktec.com/VrWeldMeshJointVideo.html


part which will form a loop of the cross-section
 - In our example, since it is a simple rectangle, we will pick 4 points around the end 
facing us when the visualizer pops up, picking in a counterClockwise direction.  Save the 
points in a file called, for example, ptLine

Close the visualizer and the Stlfiles window.

-----------------------------------------------------------------------
Open Meshing -> UserMade window or click "View Window" button below

1) - Click the New button and in the popup select MeshType: PointLine and enter a name for 
the mesh, for example, linemesh  and click OK

2) - Select the name you just created (linemesh) and Click Edit

3) - In the popup next to "Multi Point Picker" select the ptLine filename which you made 
earlier.

4) - Next to "pointLineMeshPNum" enter the part number of the part you made the linemesh 
cross-section of.  (You can see this by looking in the Setup->PartTypeInfo window next to 
the part stlfile name)  In our example, 1201

5) - Next to "pointLineMeshLoopFlag" enter 1  (This causes the linemesh to close by 
connecting the first and last points)

6) - Click Apply and OK

7) - Meshing -> UserMade -> Make
8) - Meshing -> UserMade -> Visualize

     Keep the Visualise window open and proceed to the next item in the guide

-------------------------------------------------------
Section 12.3. Mesh weld joints: Select Electrode Points
-------------------------------------------------------

In the previous item in this guide we made a linemesh which was a cross-section of the part 
we want to make filler metal on.  If it is not already, Visualize it.

This page describes the process of picking Electrode Points to make FillerMetal

* - In the Visualizer, popup Tools -> ElectrodePoints
    You probably also need the  Tools -> PointPicker-Slider

* - pick 2 points on the linemesh which will be the ends of your fillerMetal profile.  In 
our example, we want to make a filler metal profile that is 14mm wide in the center of the 
top line.  We do this by using the PointPicker-Slider

  - Select the left top corner of the rectangle with the first mouse button and click Set 
in the PointPicker-Slider next to "Start Point"
  - Select the right top corner of the rectangle with the first mouse button and click Set 
in the PointPicker-Slider next to "End Point"
  - Using the slider in the PointPicker-Slider move to the left 7mm and click Pick button 



on PointPicker-Slider (You can see the distance it moves on the slider)
  - after clicking Pick on the PointPicker-Slider go to the SetElectrodePoints window.  If 
"Electrode ID" shows 0, click the "New Electrode" button.  Then click the Set button next 
to the "Start Node"
  - repeat the process for the right point.  Move the PointPicker-Slider 7mm past the 
midpoint to the right and click Pick   Then click Set next to the "End Node" in the 
SetElectrodePoints window. 

* - Write the electrode points into a file with a name that you will recognise again.  For 
our example, we will use ep1  
  
You can pick multiple sets of Electode Points at this time if desired but since we want to 
actually pick points on the profile of the first weldMaterial to make the 2nd and 3rd 
profiles, we will now proceed to the next item in the guide, FillerMetalMaker which 
actually makes the profile you can see.

------------------------------------------------
Section 12.4. Mesh weld joints: FillerMetalMaker
------------------------------------------------

Open the Meshing -> Predefined -> FillerMetalMaker -> Edit or click the "View Window" 
button below

1)- Open the WeldJoint window and select the weldpath in question.

2) - In the FillerMetalMaker Edit window click the "Set current weldjoint" button

3) - Click the Set button next to the "Parts linemesh CDF file" and in the popup select the 
file which contains the linemesh file you made in a previous step.  The file will be the 
filename you wrote but with Mesh2 prepended.  In our example, we select Mesh2linemesh.cdf

4) - Next to the "Electrode Points" select the filename you saved your electode points in 
in the previous step.  For our example, ep1

5) - Some default numbers for parameters show up in the slots of the FillerMetalMaker -> 
Edit window.  
  For our example, we increase the number next to area:  4e-05  
  change nbElements:  100
  change dx:  0.00002

  MUST turn on "fillerMetalPointsFlag" 1  (This is because of the way we picked elecrode 
points on the surface rather than as a vector)

  The other defaults should be ok

6) - Click Apply and OK

7) - Click Meshing -> Predefined -> FillerMetalMaker -> Make

8) - Click Meshing -> Predefined -> FillerMetalMaker -> Visualize

This is now sufficient to continue for one pass.  If you want to make multipass at this 
time, go back to the "SelectElectrodePoints" item in this guide, using this new Visualizer 
to pick your points.  Open the Tools->ElectodePoints and start by loading the file you did 



before and click "New Electode". You can now pick points on the profile line of previous 
weld materials.  

Repeat as necessary to build up your multipass profile set.

------------------------------------------------------
Section 12.5. Mesh weld joints: Make PlaneSurface mesh
------------------------------------------------------

Next we will make a surface mesh using the outline of the parts cross-section and 
weldMaterial profile(s) made in previous steps

Open the Meshing -> User made window or click on the "View Window" button below.

1) - Click the New button and in the popup Select MeshType "PlaneSurface"
     enter a name that you will recognise again, for our example we just called it   
planeSurface    Click OK 

2) - Select the name you just made in the list in UserMade (planeSurface) and then click 
the Edit button.

     Next to the "Line mesh CDF file" click the Set button and in the popup select the file 
made by the previous step "MeshFillerMetalMaker-0.cdf

     Edit the other parameters as follows:
 
            dx:  0.001
compatibleFlag:  1
meshQuads:       1
makeBRepFlag:    1

3) - Click Apply and OK

4) - Click Meshing -> User made -> Make

5) - Click Meshing -> User made -> Visualize

Note: The mesh shown may have sharp corners clipped by the meshing process used
      The matching BRep file should be better. (It is written if makeBRepFlag set)

-----------------------------------------------
Section 12.6. Mesh weld joints: SurfaceReMesher
-----------------------------------------------

We will now use the BRep file from the previous step to make a better mesh of the 2D cross-
section mesh we made in the previous step

Click on the Meshing -> UserMade window or click the "View Window" button below

1) - Click the New button and in the popup Select MeshType "SurfaceReMesher"
     enter a name that you will recognise again, for our example we just called it   
surfReMesh    Click OK 

2) - Select the name you just made in the list in UserMade (surfReMesh) and then click the 



Edit button.

     Click the Set button next to the "Tri mesh CDF file" and in the popup, navigate up one 
level to the brep directory and select the file brep_electrodeFM_0.cdf  

    edit other parameters as follows:

     minElemeSize:  0.001
     maxElemSize"   0.002

3) - Click Apply and OK

4) - Click Meshing -> User made -> Make

5) - Click Meshing -> User made -> Visualize

     Check the mesh in the Visualizer by selecting View->Mesh 

-----------------------------------------------------
Section 12.7. Mesh weld joints: Make WeldJointByTube1
-----------------------------------------------------

Now, at last, we are ready to make the actual weldJoint that we will use for the analysis.

Open the WeldJoint window and select the weldpath in question

Open the Meshing -> Predefined -> WeldJointByTube1 window or click the "View Window" button 
below

1) - Click the "Set current weldjoint" button

2) - The window should still have the settings for the Big Tube that we made as the first 
item under "Mesh weldjoints" in this guide
     We will now open the menu next to "Pattern Mesh 2D" and select the mesh we just made 
in the previous step.  In our example, surfReMesh

3) - Click Apply and OK

4) - Click Meshing -> Predefined -> Make

5) - Click Meshing -> Predefined -> Visualize

     Check the mesh in the Visualizer by selecting View->Mesh 

--------------------------------------
Section 13. Setup weldjoint parameters
--------------------------------------

Setup Weld Joint Parameters Video (Click to Play)

This step can only be done after the weld joints are meshed.

Open the "WeldJoint" window or click "View Window" below.

http://www.goldaktec.com/VrWeldSetupJointParametersVideo.html


As a test, you can click "ComputeWeldingTimes" button before setting any weld joint 
parameters. This must work with the default parameters set by "LoadWeldPaths" button. If it 
doesn't work there is some inconsistency between the weld paths, weld joint meshes and 
filler metals. This has to be resolved before you go further. 

Setup parameters for all weld joints, passes and sub-passes (steps 1-6).
When you finished setting parameters for one weld joint (pass) click "Apply" button at the 
bottom before you choose another weld joint, otherwise all the new parameters will be lost.

1. Set passes using "SetPasses" button for each weld joint which has more than one pass.
2. Choose weld procedures for each weld pass. By default, the first weld procedure from the 
weld procedure list is chosen.
3. Set sub-passes for each weld joint (pass) if needed.
4. Set delay times for all weld joints, passes and sub-passes.
5. Set weld pool centers if needed.
6. Setup tack welds sizes and types for each weld pass.

7. Click "ComputeWeldingTimes" button. This computes the welding times of each sub-pass of 
each weld pass using the length of the sub-pass and the weld speed defined in the weld 
procedure.

8. Choose the Analysis type. Based on the selected type, the start times are computed using 
welding times and delay times.

------------------------------------------------------------------------
EXAMPLE 

For our PlateOnPlate example, we want to start and end our welding 25mm from the edge of 
our 200mm long part so we edit as follows:

    startWF:  0.125
    endWF:    0.875

* - Don't forget to Apply after editing for any particular weldpath.

* - Click the ComputeWeldingTimes button

* - Next to the "Tack Weld Type:" select  None  (we are welding on a single part here so we 
don't need tack welds)  Don't forget to Apply the change.

* - when we are satisfied with the parameters click OK

----------------------
Section 14. Mesh Parts
----------------------

See help for the "Setup->Part Attributes" window.
Click "View Window" button below, then press <F1> key for help.

For jobs which use "real" weldJoints, the parts are meshed using the preMesh Flag on.  
Otherwise, this flag should be off.



------------------------------------------------------------------
For our PlateOnPlate example we will do a 2 step process.

We will mesh the Plate using the MesherType: PQSurface with the preMesh flag off
Then we will cut out the elements around our weldJoint (our preMesh) and then mesh again 
using the MesherType: GeneralSheetMetal to mesh the elements that are between the weldJoint 
(premesh)and the rest of the PQMesh

To start, we know that the PQSurface mesher needs a file with 4 points on the top surface 
(patch 0) which we will pick in a counter clockwise order.

* - select the part stlfile name in the lefthand list

------------------------------------------------------------------------
* - click BRep-View Parent
* - In the visualizer that poped up, Rotate so you are looking at patch 0 (Red)
   - In the Visibility->Part  turn off all except patch 0
   - In the Visibility->Mesh  turn off all except patch 0
   - Turn on View->Mesh
   - Open Tools->MultiPointPicker and pick 4 point (In our example, pick the 4 corners of 
the rectangle)  For each point, pick with the left mouse button, click "New Point" in 
MultiPointPicker and Set button next to "Point"
   - write a file to save these pq points, say file  pq4pts_ss1
   - close visualizer

------------------------------------------------------------------------
* - Select MeshType: PQSurface and then Click Options button below
   In the popup window, on the left side next to the "Outerloop points" button select the 
pq4pts file you just wrote from the menu list
   Edit other parameters as follows:
   resolution:  0.005
   pq:          20 40
   preMeshFlag: 0
   Other parameter defaults should be ok
   Click Apply and OK
* - In the Part Attributes window click the Mesh-Make button and watch the log until it 
says Done!  
   - when the mesher says Done click Mesh-View  and check the mesh 
   - Click the Mesh-Save button (this is important if you want to keep the PQ portion of 
your mesh.  If you forget this button, you mesh will be completely done by 
GeneralSheetMetal mesher. [Which is ok but PQ is nicer])
------------------------------------------------------------------------

Now 
* - Select MeshType: GeneralSheetMetal and then Click Options button below
    Edit parameters as follows:
    MaxElementLength:  0.01
    MinElementLength:  0.002
    nbElementsAlongThickness:  3
    partMeshFlag:   1  (This says to cut out around the weldjoint (premesh)
                        from the PQ Mesh)
  - Click Apply and OK
* - In the Part Attributes window click the Mesh-Make button and watch the log until it 
says Done!  



   - when the mesher says Done click Mesh-View  and check the mesh 
   - it will have a hole where the premesh will be

------------------------------------------------------------------------
* - Click "MergeBody" button on the far right of the Part Attributes window
    and when Done  Close the window

---------------------------
Section 15. Make Total mesh
---------------------------

Make the total mesh by selecting MergeWithCMat in the Meshing window and clicking "Make" 
button (Meshing -> Predefined -> MergeWithCMat -> Make).

This merges the WeldGroup and Body meshes together. It also makes a special matrix to 
provide connectivity between WeldGroup and Body as they are not compatible in general.

The total mesh can also be viewed using Meshing -> Predefined -> Total -> Visualize.

-----------------------------
Section 16. Create subdomains
-----------------------------

See help for the Meshing -> predefined -> "ReorderElementsSD mesh parameters" window.
Click "View Window" button below, then press <F1> key for help.

--------------------------------------------------------------

For our example, edit as follows:

   Number of layers to grow from weld joint:      10
   Number of elements in weld joint subdomain:  1000

* - Click Apply and OK

* - click Meshing -> predefined -> ReorderElementsSD -> Make

* - click Meshing -> predefined -> ReorderElementsSD -> Visualize

------------------------------
Section 17. Define constraints
------------------------------

There are two types of constraints: 
1. Node fixities;
2. Stl fixities.

-----------------------------------------------
Section 17.1. Define constraints: Node fixities
-----------------------------------------------



Node fixities are the nodes which are restrained to move in sertain directions.

1. Visualize "Total" mesh (Meshing -> Predefined -> Total -> Visualize) and continue with 
SmtVisualizer GUI.

2. Tools -> Set Node Fixities.
   Read help for the "Set Node Fixities" window.

----------------------------------------------------------------------

For our example, we want to make nodal fixities such that out plate has the rigid body 
modes constrained.  We will pick 3 nodes in Y (front 2 corners and center at far end), 2 
nodes in Z on either side in mid length of the plate and 1 node in X at the center of the 
Plate.  All these nodes picked on the bottom of the plate.

Write to a file called, in our case, fix1

Note: If the mesh changes, say you mesh a different weldjoint, then you will need to repick 
these fixities

----------------------------------------------
Section 17.2. Define constraints: stl fixities
----------------------------------------------

Stl fixities are the stl files which make all adjacent nodes in the total mesh to be 
restrained to move in sertain directions. 

1. Visualize all stl files using "Setup -> Stl Files -> Visualize all stl files" or 
"Meshing -> Predefined -> ViewStl -> Visualize" and continue with SmtVisualizer GUI.

2. Tools -> Set Stl Fixities.
   Read help for the "Set Stl Fixities" window.

-------------------------------------
Section 18. Setup Boundary Conditions
-------------------------------------

Setup Boundary Conditions Video (Click to Play)

Setup Boundary Conditions

------------------------------------------------
Section 18.1. Setup Boundary Conditions: Thermal
------------------------------------------------

See help for the Setup->:Boundary Conditions" -> Thermal window.
Click "View Window" button below, then press <F1> key for help.

-----------------------------------------------
Section 18.2. Setup Boundary Conditions: Stress
-----------------------------------------------

See help for the Setup->"Boundary Conditions" -> Stress window.
Click "View Window" button below, then press <F1> key for help.

http://www.goldaktec.com/VrWeldSetupBoundaryCondVideo.html


This is where you will set the start and end times for the various Constraints files (such 
as fixities) and Forces which you have created earlier.

-------------------------------------------------------------------

------------------------------------
Section 19. Setup process parameters
------------------------------------

Various parameters mush be setup to define the specific analysis that is to be run.  What 
are the loading conditions, solvers parameters, etc

Expand this guide entry to access more detailed help for each type available.

----------------------------------------------------------
Section 19.1. Setup process parameters: Thermal parameters
----------------------------------------------------------

See help for the "Thermal Process Parameters" window.
Click "View Window" button below, then press <F1> key for help.

------------------------------------------------------------

For our example we edit the parameters as follows:

   Analysis end time:  10000.0
   Power Density button:  ON

Apply and OK

-----------------------------------------------------------------
Section 19.2. Setup process parameters: MicroStructure parameters
-----------------------------------------------------------------

There is no special MicroStructure parameters right now.

---------------------------------------------------------
Section 19.3. Setup process parameters: Stress parameters
---------------------------------------------------------

See help for the "Stress Process Parameters" window.
Click "View Window" button below, then press <F1> key for help.

----------------------------------------------------------------

For our example, set "MicroStructure Data Flow From" to "this"

   Write Time Step Stride:  10

Other default parameters are ok



------------------------
Section 20. Run Analysis
------------------------

See help for the "Run Analysis" window.
Click "View Window" button below, then press <F1> key for help.

------------------------
Section 21. View Results
------------------------

Multipass Preheat Delay Video (Click to Play)

The above video Multipass Preheat Delay shows how to setup a multi-pass analysis when each 
weld pass is delayed until the interpass temperature reaches a certain level. In this case, 
the specified interpass temperature level was 50 C or 323 K.

There are several ways to look at results of analyses from looking at colors on geometry to 
animations to making plots and comparing projects.

Each are dealt with briefly in the items under this heading.

--------------------------------
Section 21.1. View Results: Plot
--------------------------------

VrWeld can also produce several kinds of line plots from PointData vs Time to MinMax values 
over time to ETA Estimates for how long a job is expected to take which can be run during 
analysis.

More help is available using F1 on the popup windows for these menu items

----------------------------------------------------------------

To use MinMax for Temperature for example, open Plot->MinMax or click "View Window" button 
below

Pick the Field name  you want from the menus and click Run, then View Plot

You could also click ViewData button which gives it in table form

For our example, we want to start the second weldpass when the first pass cools to a 
temperature of 50C or 323K   The time when the max time cools to 323K can easily be read 
off the table.   

You could then go back to the weldJoint window, select Analysis type Manual, select the 
pass in question and set the Start Time to the value you need.  Then rerun the job either 
from the begining or from the nearest Restart file.

In Stress Process Parameters we could for example, run the first weldpass with the later 
passes set with start time way far in the future beyong the scope of the job so they won't 

http://www.goldaktec.com/VrWeldMultipassPreheatDelayVideo.html


start for the first run.  Set the Restart "Write Time Step Stride" to say 10   This mean we 
have a restart file for every 10th timestep.  We then do not need to rerun the entire job, 
just pick up from the last restart file and solve for the second pass.  repeat for the 3rd 
pass

----------------------------------------------------------------

In our example, We want to plot the NodalStress along a line from left to right across the 
center of the length of the plate.  We want this line to be 1.5mm inside the part.  We do 
this by picking with the slider on each side of the plate and the clicking Set next to 
"Node Position 1" or Node Position 2"

Set Number of points desired and set the last time step number in the "Time Step List"  and  
turn off the stride function by setting "Global Time Step Stride"  -1


